DetectingWales.com

Metal Detecting Discussions => Metal Detecting Discussions => Topic started by: dingdong on November 04, 2017, 06:51:42 PM



Title: Can you help..please!!
Post by: dingdong on November 04, 2017, 06:51:42 PM
Hi,
I seem to be having a problem with my MARS'TIGER' coil..its started falcing while out detecting yesterday.
I ground Balance as normal...and all appears well until the detector is on the left swing and the coil blips every time on the end of that left swing.
Its never been a problem in the past!!
On inspection it seems possible that there may be a problem where the cable attaches
 to the top of the coil.
Does anyone know where I can get the coil repaired please,as its a great coil,and as you all know,a new coil costs a small fortune.
Many thanks for reading..and good hunting...👍


Title: Re: Can you help..please!!
Post by: Val Beechey on November 04, 2017, 07:10:28 PM
You could give Steve Cox a ring on  0208 241 4789 or E.Mail at
www.Metaldetectorrepair.com (http://www.Metaldetectorrepair.com)

He used to be a Minelab engineer but branched out on his own. Great guy, very helpful and fair prices. If he canít help heíll probably know who can.


Title: Re: Can you help..please!!
Post by: dingdong on November 04, 2017, 07:44:16 PM
Cheers Val, already sent email...many THANKS !!


Title: Re: Can you help..please!!
Post by: Resurgam on November 04, 2017, 09:40:08 PM
Hi Chris,
              I once had similar problems with my Garrett EuroAce but it turned out to be a little bit o' sh 1 t in the control box connector!  :o


Title: Re: Can you help..please!!
Post by: dingdong on November 05, 2017, 12:05:19 AM
Thanks for the heads up Chris, I'll check it out tomorrow..if it is that it'll save me a good bitta 💰 money .. LOL 😁!!
Good hunting..👍


Title: Re: Can you help..please!!
Post by: Greg on November 05, 2017, 04:24:08 PM
Chris, if I may call you that, if it is a faulty connection you should be able to simulate it by wriggling the cable, either at the coil end or the control box end.
If you canít get it to false, it may be a problem inside the control box.
Hope this helps.


Title: Re: Can you help..please!!
Post by: dingdong on November 05, 2017, 05:38:30 PM
Hi Greg,many thanks for your input,and I really do appreciate your suggestion,and in actual fact another member of the Detecting Wales forum fraternity (Resurgam Chris ) came up with the same suggestion.....and it seems that some bits of "whatever"managed to get up onto the control box plug !!.. anyway I think it's now the problem is hopefully resolved !!.
No worries about using my first name Greg...after all we're all one big happy family.. LOL 😁!!
Thanks again,and good hunting..👍
 


Title: Re: Can you help..please!!
Post by: Resurgam on November 05, 2017, 06:55:40 PM
Hi Chris,
                pleased to hear that the problem may now have been resolve. I had a very similar problem with my EuroAce twice. The first time it was a bit of dirt in the control box connector after changing coils in the field and the second time was due to a slight coating of verdigris in the connection after not using the machine for some considerable time.

                To quote The Bard; all is well that ends well. ;)


Title: Re: Can you help..please!!
Post by: Val Beechey on November 05, 2017, 07:14:37 PM
Glad to hear you're all sorted Chris. Maybe keep Steve Cox's details somewhere safe. Always useful. ;)


SimplePortal 2.3.3 © 2008-2010, SimplePortal